ZP900 ZP900/H9500 ZP900s/H9300 Porting con Pacchetto ITA

Almerino

Utente attivo
Registrato
26 Ottobre 2013
Messaggi
86
Punti reazione
11
Questo Thread è dedicato al Porting della Miui sui terminali ZP900/H9500 e ZP900s/H9300 con integrato il Pack ITA di MIUI.IT
I device in oggetto sono gli stessi, la versione ZP900s/H9300 si differenzia per la quantità di RAM di 512M e per una diversa camera posteriore, il mio è la versione H9300.

Come base del port ho usato la versione non ufficiale presa da EN.MIUI.COM dello ZTE V970 che è l'unico con Mtk 6577, l'ho modificata per funzionare sul nostro terminale e poi ho inserito il Pack Ita di MIUI.IT

Ovviamente è una BETA e quindi vi prego di provarla e sapermi dire ....

Ecco il link alla rom, MIUI V5 - 4.03.15 + Italian Pack :
http://yadi.sk/d/fFecuo3VKe4M8

Beta precedenti:
4.01.25: http://yadi.sk/d/zr88xQFmGr7JZ
4.01.17: http://yadi.sk/d/hisUWfxGGQ5Aj


Nel mio device ho una partizione di sistema di 2.5GB, che consiglio, ma ho verificato il corretto funzionamento anche con device aventi partizione di sistema a 512MB o 1GB. La ROM si installa perfettamente ed occupa senza GAPPS circa 205MB.

Fate un backup dell’IMEI con MobileUncle e Un backup del sistema da recovery.

La ROM si installa da recovery, TWRP o CWM.

INSTALLAZIONE

1. "Wipe data/factory reset" e conferma
2. "Wipe cache partition" e conferma
3. In Advanced, "Wipe dalvik cache" e conferma
4. Install from zip e selezionate la rom scaricata
5. Per lo ZP900 installate la patch http://yadi.sk/d/KPueEXF9KiQjx

AGGIORNAMENTO

1. "Wipe cache partition" e conferma
2. In Advanced, "Wipe dalvik cache" e conferma
3. Install from zip e selezionate la rom scaricata
4. Per lo ZP900 installate la patch http://yadi.sk/d/KPueEXF9KiQjx

GAPPS x 4.2
https://drive.google.com/uc?id=0BwEZVNuL2fBWVXNvX1dQTE1nT1U&export=download

BUGS NOTI

-ZP900 autofocus camera post. non funziona
-ZP900s camera post. tende al viola

AVVERTENZE

Il sottoscritto Almerino ed il gruppo MIUI Italia non sono e non si sentono responsabili per eventuali blocchi, danni o problematiche che rendano inutilizzabile il telefono, quindi tutte le operazioni sopra descritte vengono fatte di vostra iniziativa e su vostra totale responsabilità.

Feedback, richieste e ringraziamenti sono sempre graditi. ;)

ALTRO

Ogni venerdi viene rilasciata ufficialmente dai tecnici cinesi una versione aggiornata con relativo changelog che i ragazzi di questo forum hanno la gentilezza di tradurre per noi e li trovate nelle news su miui.it, successivamente nel giro di 1 o 2 giorni viene aggiornato il pack Ita di traduzione con relativa news sempre su miui.it

Io non faccio altro che decompilare le app, inserire il pack ita e ricompilare le app.

3D relativo alla Rom di Base del V970: http://www.miui.com/thread-1382423-1-1.html
Guida alle funzioni più interessanti: http://www.miui.it/forum/index.php?threads/miui-v5-guida-alle-funzioni-più-interessanti.1835/
 
Ultima modifica:

Almerino

Utente attivo
Registrato
26 Ottobre 2013
Messaggi
86
Punti reazione
11
Chiedo a qualcuno di voi in possesso di device ZP900/H9500 di testare questa patch http://yadi.sk/d/wZ8NdnOKGQ4sb al posto di quella che trovate qui sopra, l'ho creata a partire dalla versione 3.10.25 che, mi è stato detto, non aveva il problema autofocus.
E' possibile provare la patch anche con la precedente versione 4.01.10.

Grazie in anticipo. Ciao
 
Ultima modifica:

miko88

Utente registrato
Registrato
30 Novembre 2013
Messaggi
28
Punti reazione
2
Appena provata la patch su zp900, non funziona, niente autofocus.
 

Almerino

Utente attivo
Registrato
26 Ottobre 2013
Messaggi
86
Punti reazione
11
Appena provata la patch su zp900, non funziona, niente autofocus.
Grazie miko88, provo ad aggiungere alcune librerie prese dalla 3.10.25 e faccio un'altra patch da testare, stasera, fatti un backup della Miui per il prossimo test. Ciao

AGGIORNAMENTO: Ho provato ad inserire le librerie della camera prese dalla 3.10.25 ma purtroppo non sono compatibili, molto probabilmente questa 3.10.25 proviene da una base diversa. Ho provato sul mio terminale per verificare se si installa correttamente e non ci sono problemi ma quando riavvio va in bootloop e dal log si capisce che mancano dei riferimenti sulle librerie. Aspettiamo il fix da parte del team che si occupa della Rom base. Speriamo presto ...:)
 
Ultima modifica:

Almerino

Utente attivo
Registrato
26 Ottobre 2013
Messaggi
86
Punti reazione
11

Stalingrad

Utente esperto
Registrato
6 Settembre 2013
Messaggi
439
Punti reazione
60
confermo ... e poi è di dicembre ... quel 3d è un pò indietro con la pubblicazione delle rom. ;-)
 

miko88

Utente registrato
Registrato
30 Novembre 2013
Messaggi
28
Punti reazione
2
Peccato :( ci avevo sperato...
Riusciremo mai ad avere un porting completamente funzionante per questo telefono? Prima ti fanno provare la cioccolata e poi te la tolgono...
 

Stalingrad

Utente esperto
Registrato
6 Settembre 2013
Messaggi
439
Punti reazione
60
io sono fiducioso ... Almerino è carico al punto giusto e saprà tirare fuori non solo il coniglio dal cappello ma anche "cucinato" a regola d'arte ;-)
 

Almerino

Utente attivo
Registrato
26 Ottobre 2013
Messaggi
86
Punti reazione
11
Peccato :( ci avevo sperato...
Riusciremo mai ad avere un porting completamente funzionante per questo telefono? Prima ti fanno provare la cioccolata e poi te la tolgono...

io sono fiducioso ... Almerino è carico al punto giusto e saprà tirare fuori non solo il coniglio dal cappello ma anche "cucinato" a regola d'arte ;-)

Ho messo in prima pagina il link alla rom aggiornata al 25/01, la prossima beta, dai tecnici cinesi esce il 07/02. Io nel frattempo provo a fare un port da un'altro terminale, vediamo cosa esce. Purtroppo il tempo libero si è un pò ridotto. Ciao
 

Almerino

Utente attivo
Registrato
26 Ottobre 2013
Messaggi
86
Punti reazione
11
Torno a chiedere a qualcuno di voi in possesso di device ZP900/H9500 di testare questa patch:
http://yadi.sk/d/DpSftD1tGxpKu al posto di quella che trovate nella prima pagina del thread, l'ho creata a partire da una versione presa da una Miui dei cuochi russi. E possibile provare la patch con qualsiasi precedente versione scaricata su questo forum a partire dalla 4.01.03

Grazie in anticipo. Ciao
 

AM3

Utente registrato
Registrato
2 Febbraio 2014
Messaggi
13
Punti reazione
0
Ciao Almerino...è da un po che seguo i tuoi lavori e ti faccio i complimenti. Volevo chiederti...potresti fare una patch per i moduli mt6628? ho la rom funzionante, ma non si attiva il wifi. questo perchè ha un modulo mt6628. riusciresti a fare qualcosa? in ogni caso ti ringrazio ;)
 

Almerino

Utente attivo
Registrato
26 Ottobre 2013
Messaggi
86
Punti reazione
11
Ciao Almerino...è da un po che seguo i tuoi lavori e ti faccio i complimenti. Volevo chiederti...potresti fare una patch per i moduli mt6628? ho la rom funzionante, ma non si attiva il wifi. questo perchè ha un modulo mt6628. riusciresti a fare qualcosa? in ogni caso ti ringrazio ;)
Dopo cena accendo il PC e te la faccio. Ma che telefono hai ?
 

AM3

Utente registrato
Registrato
2 Febbraio 2014
Messaggi
13
Punti reazione
0
ti ringrazio e attendo fiducioso. sto provando a fare un porting su bluebo n7100. ha le stesse identiche caratteristiche dello zopo (1gb ram, 4gb rom, mtk6577, schermo 960x540 qhd) ma ha il modulo mt6628. infatti si avvia tutto regolare, ma non si attiva il wifi all'inizio. ho fatto svariate prove ma sembra non andare. ho sostituito il boot.img della tua rom con quello stock della mia. in compenso funziona benissimo la fotocamera XD. per adesso ho visto che non funziona il wifi e la radio fm ovviamente (ma di questa non ho sostituito le lib).
 

AM3

Utente registrato
Registrato
2 Febbraio 2014
Messaggi
13
Punti reazione
0
ti ringrazio e attendo fiducioso. sto provando a fare un porting su bluebo n7100. ha le stesse identiche caratteristiche dello zopo (1gb ram, 4gb rom, mtk6577, schermo 960x540 qhd) ma ha il modulo mt6628; ho provato a vedere anche sul buil.prop. infatti si avvia tutto regolare, ma non si attiva il wifi all'inizio. ho fatto svariate prove ma sembra non andare. ho sostituito il boot.img della tua rom con quello stock della mia. in compenso funziona benissimo la fotocamera XD. per adesso ho visto che non funziona il wifi e la radio fm ovviamente (ma di questa non ho sostituito le lib).
 

Utenti online

Statistiche forum

Discussioni
33.014
Messaggi
313.994
Membri
33.075
Ultimo iscritto
NuovoGiusepp

Alto