1. Questo sito utilizza i cookies. Continuando a navigare tra queste pagine acconsenti implicitamente all'uso dei cookies. Scopri di più.

Supporto Problema fastboot Mac OsX 10.6.8

Discussione in 'Bug report e supporto' iniziata da K_Project, 30 Gennaio 2013.

  1. K_Project

    K_Project Utente attivo

    Messaggi:
    27
    "Mi Piace" ricevuti:
    2
    Ragazzi!
    Ho un problema che purtroppo ancora in nessun forum sono riusciti a darmi una mano a sistemare.
    Possiedo un macbook pro con sopra mac osx 10.6.8..
    Il mio problema è che non riesco a flashare i file di boot.img...
    Ho fatto tutto come da prassi e i comandi di adb e il fastboot devices mi riconoscono il one x collegato ma quando scrivo il famigerato "fastboot flash boot boot.img" lui di tutta risposta mi fa: " error: can't load boot.img (no such file or directory)... E qui mi chiedono tutti: ma l'immagine di boot l'hai messa nella stessa cartella dove c'è il comando di fastboot? Si certo, l'immagine l'ho sempre messa nella "platform-tools" come purtroppo faccio con windows!
    Qualcuno ha qualche consiglio da farmi provare? :)
    Grazie!
     
  2. alexxxio

    alexxxio Utente attivo

    Messaggi:
    88
    "Mi Piace" ricevuti:
    13
    Terminale:
    HTC M9
    Cambia la riga di comando inserendo nomefile.img
     
  3. K_Project

    K_Project Utente attivo

    Messaggi:
    27
    "Mi Piace" ricevuti:
    2
    Alexxxio grazie per la risposta! :)
    Io di default rinomino le immagini di boot aggiungendo una desinenza in modo da capire per quale rom sono; ad esempio "bootmiui25113.img" per capire che è quella che va con la miui del 25 gennaio 2013... Quindi non mi risolve il problema purtroppo... :(
     
  4. Mish

    Mish Admin Staff

    Messaggi:
    1.477
    "Mi Piace" ricevuti:
    689
    Terminale:
    Xiaomi Mi 5s
    Credo che alexxxio intenda dire se hai provato, usando come esempio il nome del file che hai scritto, a inviare una riga del genere "fastboot flash boot bootmiui25113.img" ? Se tenti di flashare un file boot.img che non c'è fisicamente ti da quell'errore.
     
  5. K_Project

    K_Project Utente attivo

    Messaggi:
    27
    "Mi Piace" ricevuti:
    2
    Si Mish! Ovviamente il comando lo modifico in base al file rinominato! Quindi si la sintassi del comando che scrivo è esattamente quella che hai citato te...
     
  6. Mish

    Mish Admin Staff

    Messaggi:
    1.477
    "Mi Piace" ricevuti:
    689
    Terminale:
    Xiaomi Mi 5s
    Mmm... Le uniche cose che mi vengono in mente così al volo sono la rinominazione corretta del nome file e/o il posizionamento sbagliato con il prompt dei comandi, verificato di essere nel folder giusto ? So che sembrano due stupidaggini ma spesso un piccolissimo errore quasi invisibile spiega questo genere di errori.
     
  7. K_Project

    K_Project Utente attivo

    Messaggi:
    27
    "Mi Piace" ricevuti:
    2
    Sono molto sicuro sia della nominazione dei file sia delle folder... Anche perchè non l'ho scritto ma tutti i comandi tipo: "adb devices" , " adb reboot recovery" "fastboot devices" , " fastboot erase cache" .... funzionano tutti quanti! Ho solo il problema con il comando flash... Ho provato anche a loggarmi come utente root ma non cambia niente... Non riesco proprio a capire...
     
  8. K_Project

    K_Project Utente attivo

    Messaggi:
    27
    "Mi Piace" ricevuti:
    2
    Problema risolto!! Per fortuna... :) Se qualcuno necessita di aiuto per lo stesso problema me lo dica!!
     
  9. Mish

    Mish Admin Staff

    Messaggi:
    1.477
    "Mi Piace" ricevuti:
    689
    Terminale:
    Xiaomi Mi 5s
    Ottimo, puoi condividere la tua soluzione ? Potrebbe essere utile anche ad altri utenti, grazie :)

    Sent from my Xiaomi MI-2 with Tapatalk 2
     
  10. K_Project

    K_Project Utente attivo

    Messaggi:
    27
    "Mi Piace" ricevuti:
    2
    Certo Mish!! :)
    Il problema principale era che il Mac mi effettuava tutti i comandi fastboot e adb ma soltanto se doveva leggere i dati... Comandi come fastboot flash oppure adb push non mi permetteva di eseguirli... Come già detto in precedenza il terminale era loggato come root e pensavo che bastasse quello per avere la possibilità di scrivere oltre che a leggere... Quindi dopo un pò di tentativi a vuoti trovati qui e la ho provato un istruzione che avevo usato su Ubuntu! chmod con l'aggiunta di +x e tutto è andato liscio!! :D Per tanti sarà una cosa ridicola ma per me che non sono un genio non è stato facile eheh... Lascio qui sotto la procedura usuale che uso solitamente per flashare una ROM:

    * K_Pro$ login root
    Password:
    * root# cd /Users/K_Pro/Downloads/adt-bundle-mac-x86_64/sdk/platform-tools
    * platform-tools root# chmod +x fastboot-mac
    * platform-tools root# /Users/K_Pro/Downloads/adt-bundle-mac-x86_64/sdk/platform-tools/fastboot-mac flash boot boot19198.img
    * platform-tools root# /Users/K_Pro/Downloads/adt-bundle-mac-x86_64/sdk/platform-tools/fastboot-mac erase cache
    * platform-tools root# /Users/K_Pro/Downloads/adt-bundle-mac-x86_64/sdk/platform-tools/fastboot-mac reboot
    Spero possa essere d'aiuto a qualcun altro! :)
     
    A Mish piace questo elemento.

Condividi questa Pagina