Mi4 Invalid IMEI dopo update a MM

luisbunuel

Utente attivo
Registrato
5 Febbraio 2016
Messaggi
64
Punti reazione
8
Ciao a tutti, ho un grosso problema con il mio MI4W acquistato da GB qualche settimana fa.

Premetto che inizialmente ho fatto un errore: venendo da Redmi 1s, ho flashato da updater la Miui 8 senza unire le partizioni --> hard brick da cui sono uscito seguendo questa guida http://en.miui.com/thread-226426-1-1.html

Successivamente ho seguito i consigli di angelo76 http://www.miui.it/forum/index.php?threads/aggiornamento-da-kk-a-mm-per-mi3-mi4-mi-note.15909/ ed attualmente monto la MIUI 8 Global 6.9.1 Beta.

PROBLEMA: ora il tel non legge le sim (ne ho provate diverse) e mi dà messaggi che dicono "ID dispositivo non valido: ID dispositivo dev'essere un imei valido o un indirizzo MAC. Senza l'ID dispositivo, alcune funzionalità dell'account MI non saranno disponibili".

Qualcuno ha idea di cosa possa fare? :(
Aiuto!
 

giannicoter

Super Moderatore
STAFF
Registrato
8 Marzo 2015
Messaggi
19.485
Punti reazione
3.599
Prova fare un miflash

Inviato dal mio MI 5 utilizzando Tapatalk
 

luisbunuel

Utente attivo
Registrato
5 Febbraio 2016
Messaggi
64
Punti reazione
8
Hai provato a flashare l'ultima rom fastboot e vedere se funziona? Detto ciò dai una letta qui http://en.miui.com/thread-57837-1-1.html oppure qui http://en.miui.com/thread-205120-1-1.html

Inviato dal mio xiaomi redmi 3 pro utilizzando Tapatalk
sì ho provato e mi dà lo stesso problema.
il primo link è purtroppo solo per MTK e in ogni caso il link è offline, il secondo segnala un procedimento interessante
fastboot erase modemst1
fastboot erase modemst2

purtroppo però mi dà questa risposta
erasing 'modemst1'...
FAILED (remote: partition write protected)
finished. total time: 0.016s

dici che sia perché devo prima rootare il dispositivo?

grazie mille per l'aiuto!!

N.B. mi pare impossibile che abbia formattato le cartelle necessarie all'ID, anche perchè nelle ROM 4.4 non mi dava questi messaggi.
 

angelo76

Super Moderatore
STAFF
Registrato
28 Giugno 2015
Messaggi
30.324
Punti reazione
7.861
Attendi info dai più esperti o da chi c'è già passato

Inviato dal mio xiaomi redmi 3 pro utilizzando Tapatalk
 

giannicoter

Super Moderatore
STAFF
Registrato
8 Marzo 2015
Messaggi
19.485
Punti reazione
3.599
Cerca sul web una guida per usare il tool della Qualcomm QPST per ripristinare IMEI

Inviato dal mio MI 5 utilizzando Tapatalk
 

giannicoter

Super Moderatore
STAFF
Registrato
8 Marzo 2015
Messaggi
19.485
Punti reazione
3.599
Una è quella,ne trovi altre anche su en.miui.com

Inviato dal mio MI 5 utilizzando Tapatalk
 

luisbunuel

Utente attivo
Registrato
5 Febbraio 2016
Messaggi
64
Punti reazione
8
Riassumo quello che ho fatto.
Ho provato all'incirca 4 o 5 guide, per poi capire che in effetti all'interno il telefono aveva mantenuto le cartelle efs necessarie per l'IMEI. Per esclusione, non poteva che trattarsi di un problema di rom flashata male.

Ho installato l'ultima china developer fastboot linkata da miui.it, e il problema si è risolto. Imei ok, wifi funziona ecc. Tuttavia, non avevo inserito la sim.

Successivamente, per avere l'italiano, ho flashato sempre da fastboot la global dev cancro_global_images_6.9.1_20160805.0000.29_6.0_global

Da qui in poi twrp, supersu, installo tutte le app, foto, ecc, inserisco la sim.... nessuna rete! legge la sim ma è come se fosse in modalità aereo. Non trova niente. Riavviato e provato con un'altra sim, niente da fare.

Ora sto riflashando via fastboot la global qui sopra con la sim inserita e vedo di capire dove sta il problema. Non so dove sbattere la testa.
Forse devo passare da china dev a global dev in altra maniera? Non so proprio più che pensare.

Ma soprattutto dico... Sono l'unico che ha avuto tutte ste rogne?
Ho avuto anche Meizu e LeTv (oltre a un vecchio redmi 1s) ma questo pare un incubo...

Edit: la global fastboot di cui sopra non mi trova la rete. Installata con la sim inserita. Proverò a reinstallare la china dev prima di distruggerlo scagliandolo dal terrazzo, salvo un vostro preziosissimo aiuto. Grazie
 
Ultima modifica:

giannicoter

Super Moderatore
STAFF
Registrato
8 Marzo 2015
Messaggi
19.485
Punti reazione
3.599
Fai il miflash con la china dev. Seleziona flash all,e non ti legge ancora la sim fai anche un ripristino di fabbrica da impostazioni

Inviato dal mio MI 5 utilizzando Tapatalk
 

luisbunuel

Utente attivo
Registrato
5 Febbraio 2016
Messaggi
64
Punti reazione
8
Fai il miflash con la china dev. Seleziona flash all,e non ti legge ancora la sim fai anche un ripristino di fabbrica da impostazioni

Inviato dal mio MI 5 utilizzando Tapatalk
Niente da fare. Riprovato anche con altre sim... Help :(

Per dovere di cronaca ho usato questa cancro_images_6.6.23_20160523.0000.23_6.0_cn_e787b703d4
 

giannicoter

Super Moderatore
STAFF
Registrato
8 Marzo 2015
Messaggi
19.485
Punti reazione
3.599
Ma i codici imei ci sono sul telefono? Controlla

Inviato dal mio MI 5 utilizzando Tapatalk
 

giannicoter

Super Moderatore
STAFF
Registrato
8 Marzo 2015
Messaggi
19.485
Punti reazione
3.599
Ma prima di brickare ti leggeva la sim?

Inviato dal mio MI 5 utilizzando Tapatalk
 

luisbunuel

Utente attivo
Registrato
5 Febbraio 2016
Messaggi
64
Punti reazione
8
Non l'avevo mai inserita. Però la legge, non mi dà scheda sim assente, per cui mi viene da dubitare sia un problema hardware.
 

giannicoter

Super Moderatore
STAFF
Registrato
8 Marzo 2015
Messaggi
19.485
Punti reazione
3.599
Ti conviene mandarlo indietro.magari il problema c'era anche prima di brickare

Inviato dal mio MI 5 utilizzando Tapatalk
 

luisbunuel

Utente attivo
Registrato
5 Febbraio 2016
Messaggi
64
Punti reazione
8
In realtà ora che ci penso l'ho smontato per l'hard brick, quindi ho un bel lettore mp3... :eek:
 
Ultima modifica:

luisbunuel

Utente attivo
Registrato
5 Febbraio 2016
Messaggi
64
Punti reazione
8
Ho fatto un nuovo tentativo. Provato la cyano 13, mi dà nessuna sim. Reinstallato la global dev, legge la sim ma non trova la rete. Non credo sia una questione hardware. Forse è sorto un problema provando a fixare l'imei. Non ti viene in mente nient'altro che possa provare?
 

alan0ford

Utente molto esperto
Registrato
20 Marzo 2016
Messaggi
1.231
Punti reazione
685
Tool della Qualcomm col telefono in diagnostic mode (servono anche i driver, io lo misi con *#*#717717#*#*), ma ti serve qualcuno che ti dia il suo .qcn (la guida è su http://www.androidbrick.com , io diedi il mio ad un utente del forum dopo avergli tolto il mio IMEI con un editor, ma farai fatica a trovare qualcuno disposto a farlo)
 

Utenti online

Statistiche forum

Discussioni
30.903
Messaggi
307.816
Membri
29.350
Ultimo iscritto
bapaiying7

Ultimi post

Alto