Mi4w con twrp.. Ma senza sd card... Com flashare rom?

roby972

Utente assiduo
Registrato
7 Ottobre 2016
Messaggi
154
Punti reazione
15
Ciao ho mi4w su cui prima avevo miui Italia rom, dovevo passarlo a parente e ho fatto reset tramite twrp .... Ma probabilmente ho cancellato anche il sistema perché al riavvio mi resta con logo miui.... Ora vorrei flashare rom ma non avendo slot sd e collegandolo al pc tramite cavo USB via twrp... Non me lo vede...
ComE ne esco?

Inviato dal mio Mi A1 utilizzando Tapatalk
 

roby972

Utente assiduo
Registrato
7 Ottobre 2016
Messaggi
154
Punti reazione
15
Avevo penna USB con entrata per Android ma si è rotta bel fare passaggio.... Tutte quando devono capitare...

Inviato dal mio Mi A1 utilizzando Tapatalk
 

giannicoter

Super Moderatore
STAFF
Registrato
8 Marzo 2015
Messaggi
19.585
Punti reazione
3.612
Domani compra un cavetto dai cinesi 1€

Inviato dal mio MIX 2 utilizzando Tapatalk
 

roby972

Utente assiduo
Registrato
7 Ottobre 2016
Messaggi
154
Punti reazione
15
Trovato adattatore otg... Ma é per usb type c.... Sfiga assurda.... Vabbè ne prenderò una x usb normale

Inviato dal mio Mi A1 utilizzando Tapatalk
 

roby972

Utente assiduo
Registrato
7 Ottobre 2016
Messaggi
154
Punti reazione
15
Ovviamente nei 2 store cinesi in zona introvabile.... Gia ordinato su amazon... Ci aggiorniamo settimana prox....

Inviato dal mio Mi A1 utilizzando Tapatalk
 

grattania

Utente attivo
Registrato
1 Aprile 2016
Messaggi
36
Punti reazione
13
Scarica la ROM per FastBoot e fai il flash tramite MiFlash, no?
 

roby972

Utente assiduo
Registrato
7 Ottobre 2016
Messaggi
154
Punti reazione
15
Il problema è che il pc non me lo vede.... Cell acceso con su solo la twrp... Devo provare da spento? Con mii flash?
Non mi ricordo più nulla

Inviato dal mio Mi A1 utilizzando Tapatalk
 

grattania

Utente attivo
Registrato
1 Aprile 2016
Messaggi
36
Punti reazione
13
Il problema è che il pc non me lo vede.... Cell acceso con su solo la twrp... Devo provare da spento? Con mii flash?
Non mi ricordo più nulla

Inviato dal mio Mi A1 utilizzando Tapatalk
Guarda qua: http://en.miui.com/a-234.html

Ti serve il programma MiFlash e la ROM in formato FastBoot.
Il cellulare dovrai avviarlo tenendo premuto il Volume Giù finchè non entra in modalità FastBoot


Poi, aspetta un attimo, giusto per essere sicuro: con il fatto che il cellulare non venga visto dal pc, cosa intendi? Hai già provato a connetterlo mentre sei nella TWRP e verificato che i comandi ADB non funzionano?

Ho dato per scontato che non funzionino, ma effettivamente mi sembra strano. Se funzionassero, io caricherei lo zip della ROM nella memoria interna del cell tramite ADB e, voilà, dalla TWRP poi potrai direttamente re-installare la ROM
 
Ultima modifica:

roby972

Utente assiduo
Registrato
7 Ottobre 2016
Messaggi
154
Punti reazione
15
Guarda qua: http://en.miui.com/a-234.html

Ti serve il programma MiFlash e la ROM in formato FastBoot.
Il cellulare dovrai avviarlo tenendo premuto il Volume Giù finchè non entra in modalità FastBoot


Poi, aspetta un attimo, giusto per essere sicuro: con il fatto che il cellulare non venga visto dal pc, cosa intendi? Hai già provato a connetterlo mentre sei nella TWRP e verificato che i comandi ADB non funzionano?

Ho dato per scontato che non funzionino, ma effettivamente mi sembra strano. Se funzionassero, io caricherei lo zip della ROM nella memoria interna del cell tramite ADB e, voilà, dalla TWRP poi potrai direttamente re-installare la ROM
Ok grazie appena ho un attimo di tempo provo

Inviato dal mio Mi A1 utilizzando Tapatalk
 

grattania

Utente attivo
Registrato
1 Aprile 2016
Messaggi
36
Punti reazione
13
niente miflash non lo vede neanche in fastboot
Se sul cellulare c'era il classico robottino della modalità fastboot, allora direi che il problema potrebbe essere:
1. porta usb o cavo usb difettosi (poco probabile)
2. driver per la modalità fastboot non installati correttamente (più probabile)

Ma quando colleghi il cellulare al pc appare la classica notifica di un qualche dispositivo collegato in basso a destra?
 

roby972

Utente assiduo
Registrato
7 Ottobre 2016
Messaggi
154
Punti reazione
15
Se sul cellulare c'era il classico robottino della modalità fastboot, allora direi che il problema potrebbe essere:
1. porta usb o cavo usb difettosi (poco probabile)
2. driver per la modalità fastboot non installati correttamente (più probabile)

Ma quando colleghi il cellulare al pc appare la classica notifica di un qualche dispositivo collegato in basso a destra?
No nessuna notifica sul pc....

Inviato dal mio Mi A1 utilizzando Tapatalk
 

grattania

Utente attivo
Registrato
1 Aprile 2016
Messaggi
36
Punti reazione
13
No nessuna notifica sul pc....

Inviato dal mio Mi A1 utilizzando Tapatalk
Ok allora con il cellulare in modalità fastboot e connesso al pc, vai in Pannello di Controllo --> Gestione Dispositivi, clicca su "rileva modifiche hardware" e vediamo se appare qualche dispositivo con il punto di domanda


(Occhio a non prosciugare la batteria del Mi4 alla fine :D Credo si riesca a caricare solo mentre sei nella twrp)
 

roby972

Utente assiduo
Registrato
7 Ottobre 2016
Messaggi
154
Punti reazione
15
Ora si.... Scarico la rom e provo a flashare.... Serbe in formato tgz? Perché quella in formato zip non la vede... Devo unzipparla?

Inviato dal mio Mi A1 utilizzando Tapatalk
 

roby972

Utente assiduo
Registrato
7 Ottobre 2016
Messaggi
154
Punti reazione
15
Ho cambiato 3 porte USB...

Inviato dal mio Mi A1 utilizzando Tapatalk
 

grattania

Utente attivo
Registrato
1 Aprile 2016
Messaggi
36
Punti reazione
13
Ora si.... Scarico la rom e provo a flashare.... Serbe in formato tgz? Perché quella in formato zip non la vede... Devo unzipparla?

Inviato dal mio Mi A1 utilizzando Tapatalk
La ROM del fastboot devi estrarla per due volte. Devi scaricarla, è diversa rispetto a quelle che si installano tramite twrp

Comunque sia secondo me anche la strada della twrp con i comandi adb dovrebbe funzionare
 
Ultima modifica:

roby972

Utente assiduo
Registrato
7 Ottobre 2016
Messaggi
154
Punti reazione
15
flashato ...ad un certo punto mi da errore

"remote data too large"

sblagiato rom?


stavo flashando questa
cancro_global_images_V9.5.7.0.MXDMIFA_20180815.0000.00_6.0_global

https://imgur.com/a/MD2yINp
 

grattania

Utente attivo
Registrato
1 Aprile 2016
Messaggi
36
Punti reazione
13
flashato ...ad un certo punto mi da errore

"remote data too large"

sblagiato rom?


stavo flashando questa
cancro_global_images_V9.5.7.0.MXDMIFA_20180815.0000.00_6.0_global

https://imgur.com/a/MD2yINp
Usa la versione 2016.08.30 del MiFlash (https://en.miui.com/forum.php?mod=viewthread&tid=345974&extra=page=1&page=1&mobile=no). Risulta essere la più stabile per il Mi4.
Se il problema persiste, prova a usare altre porte usb del pc (non mi ricirdo bene, ma ogni tanto capitava che le porte 3.0 o 2.0 facessero capricci)
 

Utenti online

Statistiche forum

Discussioni
31.206
Messaggi
308.172
Membri
29.929
Ultimo iscritto
jimmyzoe

Nuovi post profilo

MatteoV ha scritto sul profilo di giannicoter.
Ciao sono un nuovo iscritto, posso chiederti un aiuto?
Alto